Bugs and suggestions from EvilSpirit


#1

Hello, Rayan
Can I put all my things here? So… Begin.

  1. I imported very large mesh (200mm) but contangent says it is small (The imported mesh is very small…)!
  2. Instead of floating point values I see 02 (instead of 0.2). That is hell because my lang culture use “,” as delimiter, so you have to google how to work with this well. I spent several hours to make it work for my own C# project.
  3. Why error object is grey? This should be red and should bleed with big drops of blood! I haven’t figure it out before trying to slice something.
  4. Why It anyway slices it? If objects not solids, it should’nt slice it. It should show you big red message with error and suggestion to fix it automatically.
  5. Ctrl+Z is totally broken.
  6. It is very smart to hide gizmo axis from me! Can’t it just be reversed in order to be always available?
  7. Can this overtesselated cylinder be removed just after importing a mesh? I can’t believe someone need it.
  8. Can’t we center imported mesh automatically?

#2

Hi, welcome EvillSpirit,

@2: I had the separator issue as well (on a macOS pre-beta version as well as on a VM installation on macOS) being on German localisation (standard separator is colon here). No matter whether I set the OS to use fullstops instead of colon > Cotangent ignored it. You need to set the localisation to one that uses fullstops by default. I set it to English and all was fine.
@3/4: Cotangent is able to get GCode from open parts too. That’s a feature not a bug. If you want an object to be ignored you need to set it to ObjectType: Ignore in the bottom/left panel at its Object tab.
@ 7: Via the More… button you can get an empty scene. That’s what I do at first to get rid of the cylinder - Overtesselated ? - I see nice even meshing without CAD-like stretched triangles.
@ 8: via the gear icon at top you can get Preferences. There you can set the behaviour of ImportTransformMode to AutoCenterFirst or AutoCenterAll


#3

a second forum user - exciting! =)

  1. sorry, is a bug
  2. this will be fixed in next update, it is a bug in Unity but I have a workaround.
  3. grey does not mean error, it just means not-closed.
  4. There are reasons to have open meshes, the first picture on cotangent.io shows an example of where you might want to use open meshes (as magweb says). I do use red for actual errors inside the tools.
  5. can you give me an example? I also use ‘z’ as a hotkey so if you don’t hit ctrl all the way, it does the ‘z’ hotkey, which flips Y/Z-up. This happens to me sometimes. In next release this hotkey will be Shift+Z and so no accidents. (possibly you hit another bug in which case please explain in a separate post)
  6. working on this, however the actual coordinate system is +z == back…
  7. use Open to open mesh files if you want a new scene. Import to add additional files.
  8. as magweb explained. Alternately the ‘n’ hotkey will center the selected mesh.

#4

Ok I changed the behavior so if you do import on the default cylinder, it removes it. Next update will be coming out on monday or tuesday.

I can’t reproduce your 200mm == small issue…is it small on other axes? maybe you can post mesh? I tried some large meshes and it says “very large”…


#5

This mesh is warned as too small:


#6

Seems Cotangent beta 1.03 takes the Z dimension only to decide whether an object is small or large (object’s BB here is 165x81x12.5)
If one rotates the object somewhere external (e.g to 165x12.5x81) its same size is considered to be large by the import assistant.

Would be nice if Cotangent calls Resize after an import automatically? And maybe a button to switch the object’s Up on this panel?